Mobilsiden.dk  /   Nyhedsoversigt  /   Gamle Android-versioner spøger stadig

Gamle Android-versioner spøger stadig

Android version 2.3 Gingerbread får så småt større udbredelse. Men 74 procent kører stadig med forældede Android-versioner på deres smartphones.

Data indsamlet i 14 dage op mod den 1. august 2011 viser, at Android 2.3 til 2.3.4 nu findes på 24,3 procent af Android-mobilerne i markedet.
Data indsamlet i 14 dage op mod den 1. august 2011 viser, at Android 2.3 til 2.3.4 nu findes på 24,3 procent af Android-mobilerne i markedet.

Ifølge Google aktiveres der over en halv million nye Android-enheder på verdensplan, hver eneste dag. Og nu viser de nyeste tal fra udviklingsteamet bag Android, at Android 2.3 Gingerbread har fået større udbredelse.

Data indsamlet i 14 dage op mod den 1. august 2011 viser, at Android 2.3 til 2.3.4 nu findes på 24,3 procent af Android-mobilerne i markedet.

Tilbage i maj måned udgjorde disse versioner af Android kun fire procent.

Det interessante ved statistikken er, at 74,4 procent af alle android enheder, stadig kører gamle versioner af styresystemet.

Læs også:
- Hvordan startede Android?

Forrige artikel Næste artikel

Få notikationer:

Læs Mobilsidens debatregler her


Kommentar

BE 04-08-2011 22:42:56

Versioner eller ej, så er det noget bæ(!) i forhold til det gamle Symbian på min C905 fra SE.
- Det gælder også mine tidligere SE mobiler med Symbian!

Hvordan fanden kan sådan noget møg, som Android klemme sig frem i forreste linie?

Blev mobilerne så billigere(NEJ), - jamen styresystemet var jo gratis i modsætning til tidligere!(hardwaren er trods alt ikke så forskellig, at det betyder noget)

Samsung Galaxy S, - den store åbenbaring(!), med verdens måske elendigste styresystem indlagt - Eclair 2.1.
På en almindelig hverdag var det nødvendigt, at tage batteriet ud flere gange dagligt, og genstarte mobilen.
- Der gik omkring et år inden opdateringen til Froyo 2.2 blev udsendt.
- Vist hjalp det da, men du fredsens kineser hvor mangler der fortsat meget, og det er stadig ikke stabilt.

- Jeg tænker på min PC, når jeg går fra den om morgenen, så fungerer den stadig om aftenen, og næste morgen, når jeg tager den i brug. Det er jo en ren drømmetilstand for min mobil, - noget der måske aldrig vil blive virkeligt.
- Den er ovenikøbet mere kompliceret end min mobil!(og så med alle mulige programmer, der stadig kører og fungerer)

Mine SE moobiler kom der rettelser til, - men det var så langt ude i systemet, at jeg overhovedet ikke bemærkede det.

Nu skal så leve med et elendigt styresystem Android 2.2 (Froyo) på min Galaxy S, og afvente Samsungs sendrægtighed med Android 2.3.x når den engang ad åre kommer, - og om det så bliver bedre er jeg da ret tvivlende overfor, når de kan starte med at levere sådan noget l... til at begynde med.

Sammenligningen med min PC er både nærliggende og rimelig, ligesom forskelbetragtningen med mine SE mobiler tidligere.

Windows 7, Vista elelr XP kan jeg lægge på alle mine Pcer uden problemer, ligesom mine programmer i store træk, - men min mobil SGS der også har et styresystem kan sgu ikke engang fungere i en måned uden batteriet skal ud 2 eller 3 gange i samme tidsrum.

Android er noget opreklameret skidt uden lige, der aldrig burde have været på markedet!
At producenterne vil lægge navn til dette misfoster er ganske ubegribeligt!

0 0
Martin 04-08-2011 12:13:04

At der er kommet 2.3 er ikke ensbetydende med at 2.2 er forældet. Det er ældre, ja, men ikke *for*ældet.

Som Android udvikler er det vigtige for mig hvor mange begrænsninger jeg må lave i forhold til versionen, og her frembyder 2.2 overhovedet ingen problemer.

Når vi kommer ned på fx 1.6 mener jeg helt klart at det er forældet. Så er der en masse hensyn at tage som udvikler.

0 0
Jesper 05-08-2011 11:07:50

...men at skrive at det er forældet, stemmer jo meget godt overens med mobilsiden.dk's afstandstagen fra ét OS til fordel for et andet OS! Rimeligt gennemskueligt, og ret useriøst!

Kigger man på statistiken, kører ca. 20% 2.1 eller ældre, 55,9% kører 2.2 og resten kører 2.3.x eller 3.x.
2.2.x må siges at være en okay variant langt hen ad vejen, og opgraderingen til denne på f.eks. Incredible S resulterede naturligvis i en bedre telefon, men ikke på nogen skelsættende måde.

Men klart, vil man rakke et konkurrerende OS ned, er det jo altid muligt at ty til statistikker. De er jo dejligt taknemmelige og fleksible!

0 0
Mobilsiden 04-08-2011 13:21:53

@Martin: Beklager at meddele, men om det er 2.1, 2.2 eller 2.3 har også betydning for udviklerne.

Se f.eks. YouTube (https://market.android.com/details?id=com.google.android.youtube&feature=search_result) den kræver Android 2.2 eller højere... Der er allerede lignende applikationer, som kræver Android 2.3...

0 0
Morten Jensen 04-08-2011 14:15:05

Det er ikke det Martin skriver.
At man som en udvikler af en Android App sætter minimum API level til det nyeste, er ikke ens betydende med, at App'en ikke ville kunne køre med en lavere API level.
Kort sagt: En App kan meget vel sagtens kunne fungere på ældre Android versioner, men hvis udvikleren vælger at sætte baren ved f.eks. Android 2.3, så vil det kun være muligt at installere App'en på telefoner med Android 2.3 eller nyere. Selvom App'en højst sansynligt ville fungere perfekt på enheder med ældre Android version, hvis der ikke gøres brug af nogle specifikke features som kun findes i 2.3

Dét Martin skriver er, at de features som findes i 2.2 er rigelig til at lave de apps, som han har haft behov for at lave.

0 0
Mark 05-08-2011 11:57:57

Der er jo nok en grund til en udvikler vælger en minimumsgrænse...

Ofte bliver der jo ting tilgængeligt i nyere versioner, og derfor må man skære fra.

Tror du skulle tjekke hvad der bliver tilgængeligt mellem versionerne før du formoder at noget sagtens vil kunne fungere på en lavere version. :)

0 0
Morten Jensen 05-08-2011 12:11:02

Jeg skriver ikke, at der ikke sker noget nyt i hver enkelt version.

Det jeg mener er, at det nok er de færreste udviklere der, når de får en specifik opgave, med 100% nøjagtighed kan sige, hvilken Android version der som minimum er påkrævet til den pågældende opgave. Derfor vælger de fleste nok at sætte minimum API level til Android 2.2 eller 2.3 på nuværende tidspunkt. Dette gøres ud fra den simple logik, at jo højere man sætter API level, jo mere funktionalitet har man til rådighed.

Jeg tror bare på, at langt de fleste apps sagtens kunne fungere uden problemer på f.eks. 2.2, selvom API level er sat til 2.3. Alene ud fra ovenstående tese.

0 0
Martin 04-08-2011 14:14:58

Jeg skriver jo ikke at det ikke har betydning! Jeg skriver bare at det IMO ikke er det samme som at 2.2 er forældet.

Sagt på en anden, så har jeg ikke haft brug for noget som kun 2.3 kan, eller som ikke på en meget nem måde kan opnås alligevel med 2.2.

Derfor er det at jeg skriver at jeg ikke finder det noget problem at udvikle til 2.2, men det er ikke det samme som at der ikke er forskel :-)

0 0
DX 04-08-2011 11:17:41

forældede iPhones er stadig i kredsløb

0 0
BonBon 04-08-2011 10:37:13

Hej John,

Burde det ikke give sig selv set i lyset af bindinger (abonnementer) i udlandet er op til 24 mdr. også set i lyset af at ikke alle producenter har frigivet 2.3 eller 2.3.4 til alle deres modeller. Og endnu at alle ikke opdaterer via FOTA.

0 0
Robert 04-08-2011 10:51:45

Ja der er stadig mange 1-2 år gamle android modeller i omløb, som formentlig aldrig bliver opdateret. Bare se sidste års HTC-topmodel Desire hvor mange forbehold de har været nød til at tage. Legend, Hero, wildfire vil aldrig få den. De fleste folk skifter også først telefon når den gamle er død, ikke alle er med i nørde-racet.

Hørte i øvrigt for nylig om 3-års mobil-bindinger i Canada, helt forrykt. Så betaler man stadig af på sin Iphone 2 når 5'eren kommer ud :)

0 0
Robert 04-08-2011 10:53:38

Nåja og så er der jo LG optimus black, 2x og 3D de bliver heller aldrig opdateret fra 2.2 :)

0 0

Om brug af cookies